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

  เป นบอร ดไมโครคอนโทรลเลอร  32 บ ิตที ่ม ีวงจรเชื ่อมต อพอร ต USB เพื ่อสื ่อสารข อม ูล
และอ ัปโหลดโปรแกรม   เล ือกใช ฮาร ดแวร และซอฟต แวร จากโครงการไมโครคอนโทรลเลอร 
ระบบเป ด (โอเพ นซอร ส : open source) ที ่ชื ่อ Arduino (www.arduino.cc) มาปร ับปร ุงต อ ม ีไลบราร ีฟ งก ชั ่น
ภาษาซ ีส ําหร ับต ิดต อก ับฮาร ดแวร จ ํานวนมากไว ให  ท ําให เข ียนโปรแกรมสั ่งงานอ ุปกรณ ต างๆ ได ง าย โดย
ไม ต องศ ึกษาลงไปในรายละเอ ียดของไมโครคอนโทรลเลอร มากน ัก

ส วนประกอบทั้ งหมดของบอร ด  แสดงในรู ปที่  1-1 มี คุ ณสมบั ติ โดยสรุ ปดั งนี้ 

 ใช ไมโครคอนโทรลเลอร ขนาด 32 บิ ตเบอร  STM32F103CBT6 มี หน วยความจํ าแฟลช
128KB โปรแกรมใหม ได  10,000 ครั้ ง มี หน วยความจํ าข อมู ลแรม 20KB สั ญญาณนาฬิ กา 20MHz

รู ปที่  1-1 ส วนประกอบของบอร ด 
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 จุ ดต อพอร ตแบบ JST 3 ขา 11 จุ ดสํ าหรั บต ออุ ปกรณ ตรวจจั บและอุ ปกรณ ต อพ วง

 ม ี LED แสดงสถานะไฟเลี ้ยง, แจ งเต ือนแบตเตอรี ่อ อน และสถานะการเชื ่อมต อพอร ต USB

 มี สวิ ตช  RESET

 มี จุ ดต อพอร ต USB  สํ าหรั บดาวน โหลดโปรแกรมและสื่ อสารข อมู ลกั บคอมพิ วเตอร 

 มี จุ ดต อไฟเลี้ ยงผ านทางจุ ดต อสายแบบขั นสกรู  รั บไฟเลี้ ยง 6 ถึ ง 9V มี สวิ ตช เป ด-ป ด

 ใช กั บแบตเตอร่ี ลิ เธี ยมโพลี เมอร ได สู งสุ ด 2 เซล (7.4V สู งสุ ดไม เกิ น 8.4V)

 มี วงจรควบคุ มไฟเลี้ ยง 3.3V เพื่ อจ ายให กั บไมโครคอนโทรลเลอร , จอแสดงผล OLED
และจุ ดต อพอร ตอิ นพุ ตเอาต พุ ตหลั ก

 จุ ดต อพอร ตอ ินพุ ตเอาต พุ ตดิ จิ ตอลหรื ออะนาลอก 9 ช อง คื อ A0 ถึ ง A8 (ตรงกั บขา PA0
ถึ ง PA7 และ PB0) รองรั บการทํ างานเป นขาอิ นพุ ตรั บสั ญญาณอิ นเตอร รั ปต จากภายนอก

 จุ ดต อพอร ตดิ จิ ตอลรองรั บระบบบั ส I2C  2 ชุ ดคื อ จุ ดต อ SDA และ SCL ต อพ วงกั น
โดยใช คอนเน็ กเตอร แบบ PH4 จั ดขาแบบ GROVE

 ม ีจ ุดต อพอร ตสื ่อสารข อม ูลอน ุกรม UART ค ือ จ ุดต อพอร ต PB7 (RxD) และ PB6 (TxD)

 มี วงจรขั บมอเตอร ไฟตรง 4 ช อง พร อม LED แสดงสถานะการทํ างาน ใช จุ ดต อแบบ
คอนเน็ กเตอร  IDC 2 ขาและแบบเทอร มิ นอลบล็ อก 2 ขาต อช อง รองรั บมอเตอร ไฟตรง 3 ถึ ง 9V มี 
ความสามารถขั บกระแสไฟฟ าได ต อเนื่ อง 1.5A ต อช อง สู งสุ ดไม เกิ น 2A มี วงจรจํ ากั ดกระแสไฟฟ า
เกิ นเพื่ อป องกั นความเสี ยหายที่ อาจเกิ ดขึ้ นกั บตั วบอร ด

 ม ีจ ุดต อขาพอร ตของไมโครคอนโทรลเลอร ส ําหร ับข ับเซอร โวมอเตอร  6 ช องค ือ จ ุดต อ SERVO1
(PB10), SERVO2 (PB3), SERVO3 (PC15), SERVO4 (PC14), SERVO5 (PA15) และ SERVO6 (PB11)

 มี ลํ าโพงเป ยโซสํ าหรั บขั บเสี ยง โดยต อกั บขาพอร ต PB5

 มี จอแสดงผล OLED 1.5 นิ้ ว ความละเอี ยด 128 x 64 จุ ด แสดงภาพกราฟ กลายเส นและ
พื้ นสี  แสดงผลเป นตั วอั กษรขนาดปกติ  (5 x 7 จุ ด) ได  21 ตั วอั กษร 8 บรรทั ด ติ ดต อผ านบั ส I2C

 มี สวิ ตช กดติ ดปล อยดั บพร อมใช งาน 3 จุ ด

1. สวิ ตช  OK (ปุ มสี เหลื อง) ต อร วมกั บตั วต านทานปรั บค าได   (KNOB) ซึ่ งเชื่ อมต อ
ไปยั งขาพอร ต PB1 ทํ าให อ านค าสั ญญาณดิ จิ ตอลและอะนาลอกได ในขาพอร ตเดี ยวกั น

2. สวิ ตช  A (ปุ มสี ส ม) ต อกั บขาพอร ต PC13 และ LED สี ฟ าเพื่ อแสดงสถานะลอจิ ก

3. สวิ ตช  B (ปุ มสี ขาว) ต อกั บขาพอร ต PB2 และ LED สี เขี ยวเพื่ อแสดงสถานะลอจิ ก
 มี วงจรตั วต านทานปรั บค าได  KNOB พร อมปุ มปรั บเพื่ อใช ในการทดสอบวงจรแปลง

สั ญญาณแอนะล็ อกเป นดิ จิ ทั ลบนบอร ด ต อกั บขาพอร ต PB1 โดยต อร วมใช งานกั บสวิ ตช กด OK
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 

Arduino IDE

การพั ฒนาโปรแกรมให กั บบอร ด  ในที่ นี้ เลื อกใช โปรแกรมภาษา C/C++ โดยใช 
แพล็ ตฟอร มระบบเป ดที่ ชื่ อ Arduino ซอฟต แวร หลั กคื อ Arduino IDE ที่ จั ดการทั้ งกระบวนการจบ
ด วยโปรแกรมเพี ยงตั วเดี ยว ตั้ งแต มี ส วนของการสร างโค ดภาษา C/C++ มี ไลบรารี มาตรฐาน ตั วแปล
ภาษา C/C++ หรื อคอมไพเลอร  ลิ งเกอร  และส วนของการอั ปโหลดโค ดไปเขี ยนลงในหน วยความจํ า
โปรแกรมของไมโครคอนโทรลเลอร  ในบทนี ้นํ าเสนอขั ้นตอนการต ิดตั ้งโปรแกรม Arduino ไปจนถ ึง
การทดสอบใช งานเบื้ องต น

2.1 การติ ดตั้ งซอฟต แวร  Arduino IDE บนระบบปฏิ บั ติ การ Windows

2.1.1 การติ ดตั้ ง Arduino IDE และไดรเวอร  USB

มี ขั้ นตอนดั งนี้ 

(1) เชื ่อมต อคอมพ ิวเตอร เข าก ับเคร ือข ายอ ินเทอร เน ็ต จากนั ้นเป ดเว ็บบราวเซอร ไปย ังเว ็บไซต 
Arduino ท ี่  https://www.arduino.cc จากนั ้นคล ิกที ่ห ัวข อ SOFTWARE ตามร ูปที ่ 2-1

ร ูปที ่ 2-1 หน าเว ็บของ Arduino
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(2) เลื่ อนแถบลงมาด านล าง ค นหาหั วข อ Legacy IDE เลื อกรายการ Windows Win 7 and
Newer เพื่ อดาวน โหลดไฟล ติ ดตั้ งซอฟต แวร  Arduino IDE เวอร ชั่ น1.8.X ตามรู ปที่  2-2

(3) จากนั้ นจะปรากฏหน าต างตามรู ปที่  2-3 คลิ กที่ ปุ ม JUST DOWNLOAD เพื่ อดาวน โหลด
ไฟล ติ ดตั้ ง

ร ูปที ่ 2-2 แสดงการเล ือกดาวน โหลดไฟล ต ิดตั ้งซอฟต แวร  Arduino IDE เวอร ชั ่น 1.8.X

ร ูปที ่ 2-3 แสดงปุ ม JUST DOWNLOAD สํ าหร ับดาวน โหลดซอฟต แวร  Arduino IDE
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(4) ทํ าการดั บเบิ ลคลิ กที่ ไฟล ติ ดตั้ งซอฟต แวร  Arduino IDE จะปรากฏหน าต างสํ าหรั บเริ่ มต น
การติ ดตั้ งโปรแกรม Arduino IDE ตามรู ปที่  2-4

(5) จากนั้ นจะปรากฏหน าต างเลื อกส วนประกอบของโปรแกรมที่ ต องการติ ดตั้ งแสดงขึ้ นมา
ตามรู ปที่  2-5 คลิ กปุ ม Next

(6) หน าต างเลื อกโฟลเดอร สํ าหรั บติ ดตั้ งโปรแกรมดั งรู ปที่  2-6 ปรากฏขึ้ นมา คลิ กปุ ม Install
เพื่ อเริ่ มต นการติ ดตั้ งโปรแกรมArduino

(7) จากนั้ นรอจนกระทั่ งการติ ดตั้ งโปรแกรมเสร็ จสมบู รณ  ตามรู ปที่  2-7 คลิ กปุ ม Close เพื่ อ
ป ดหน าต างนี้ 

รู ปที่  2-4 แสดงหน าต างแจ งยอมรั บลิ ขสิ ทธิ์ ก อน
เริ ่มต นการต ิดตั ้งโปรแกรม Arduino IDE

ร ูปที ่ 2-5  หน าต างเล ือกส วนประกอบของโปรแกรม
Arduino IDE ที ่ต องการต ิดตั ้ง

รู ปที่  2-6 หน าต างสํ าหรั บเลื อกโฟลเดอร ติ ดตั้ ง
โปรแกรม

รู ปที่  2-7 แสดงการติ ดตั้ งโปรแกรม Arduino IDE
เสร ็จสมบ ูรณ 
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2.1.2 การติ ดตั ้งฮาร ดแวร และไลบราร ีสํ าหรั บใช งานบอร ด  

เมื ่อติ ดตั้ งโปรแกรม Arduino IDE เรี ยบร อยแล ว ลํ าดั บถั ดไปคื อ การทํ าให โปรแกรม Arduino
IDE ทํ างานกั บบอร ด  ได ด วยการเพิ่ มข อมู ลทางฮาร ดแวร และติ ดตั ้งไลบรารี สํ าหรั บการพั ฒนา
โปรแกรมด วยภาษา C/C++ ให ก ับ Arduino IDE รวมถ ึงท ําให เครื ่องมื อในการอ ัปโหลดโปรแกรมของ
Arduino IDE สามารถทํ าการอั ปโหลดโค ดมายั งบอร ด  ได 

มี ขั้ นตอนดั งนี้ 

(1) เป ดโปรแกรม Arduino IDE  ปรากฏหน าต างหล ักของโปรแกรม Arduino IDE ด ังร ูปที ่ 2-8

(2) เลื อกเมนู  File > Preferences… ตามรู ปที่  2-9

(3) หน าต าง Preferences ปรากฏขึ้ นมาตามรู ปที่  2-10 ทํ าการตั้ งค าดั งนี้ 

๐ คลิ กที่ รายการ Verify code after upload เพื่ อนํ าเครื่ องหมายถู กออก

๐ คลิ กที่ รายการ Check for updates on startup เพื่ อนํ าเครื่ องหมายถู กออก

๐ ที่ รายการ Additional Boards Manager URLs: กํ าหนดค าเป น
https://github.com/INEXdev/ArduinoSTM32/raw/main/package_inex_stm32_index.json

จากนั้ นคลิ กปุ ม OK เพื่ อยื นยั นการตั้ งค า

ร ูปที ่ 2-8 หน าต างหล ักของโปรแกรม Arduino IDE
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ร ูปที ่ 2-9 การเล ือกเป ดหน าต าง Preferences ของโปรแกรม Arduino IDE

ร ูปที ่ 2-10 แสดงการตั ้งค าหน าต าง Preferences เพ่ื อเตร ียมการต ิดตั ้งข อม ูลของบอร ด 
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 (4) เลื อกเมน ู Tools > Board:xxx > Boards Manager… ตามรู ปที่  2-11

(5) หน าต าง Boards Manager ปรากฏขั้ นมาตามรู ปที่  2-12 ให พิ มพ ค นหาด วยคํ าว า INEX
จะพบรายการตั วติ ดตั้ งข อมู ลทางฮาร ดแวร ชื่ อ INEX_STM32 ซึ่ งมี ข อมู ลของบอร ด  รวมอยู 
ด วย จากนั้ นคลิ กปุ ม Install เพื่ อทํ าการติ ดตั้ ง

ร ูปที ่ 2-11 แสดงการเล ือกเมน ู Tools>Board:xxx>Boards Manager…

ร ูปที ่ 2-12 แสดงหน าต าง Boards Manager ส ําหร ับต ิดตั ้งไลบราร ีและข อม ูลทางฮารแวร ของ INEX_STM32
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ร ูปที ่ 2-13 แสดงการเล ือกบอร ด 

ร ูปที ่ 2-14 แสดงการเล ือกว ิธ ีการอ ัปโหลดโค ดเป น HID Bootloader 2.2
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(6) จากนั้ นเข าสู กระบวนการติ ดตั้ งไลบรารี  รอจนกระทั่ งการติ ดตั้ งเสร็ จสมบู รณ 

ขั ้นตอนถ ัดไปเป นทดสอบอ ัปโหลดโปรแกรมไปย ังบอร ด   เพื ่อย ืนย ันว า การต ิดตั ้งข อม ูล
ฮาร ดแวร และไลบราร ีของบอร ด  ให ก ับโปรแกรม Arduino IDE ถ ูกต องและพร อมใช งาน

(7) ต อสาย USB เพื่ อเชื่ อมต อบอร ด   กั บคอมพิ วเตอร 

(8) จ ายไฟเลี้ ยงให บอร ด   และเป ดสวิ ตช  POWER

(9) ที ่หน าต างหล ักของโปรแกรม Arduino IDE เล ือกเมน ู Tools > Board:xxx > INEX STM32
> POP-32 ตามรู ปที่  2-13

(10) เลื อกวิ ธี การอั ปโหลดโค ด โดยเลื อกเมนู  Tools > Upload method: “HID Bootloader
2.2” > HID Bootloader 2.2 ตามรู ปที่  2-14

(11) เลื อกพอร ตอนุ กรมสํ าหรั บการสื่ อสารข อมู ลกั บโปรแกรม Arduino IDE โดยเลื อกเมนู 
Tools > Port: “xxx” > XXXXX ตามรู ปที่  2-15 โดยในส วนนี้ หมายเลขพอร ตเชื่ อมต อพอร ต USB
ระบบปฏิ บั ติ การจะเป นตั วกํ าหนดให  ในที่ นี้ คื อ COM62

ร ูปที ่ 2-15 แสดงการเล ือกพอร ตอน ุกรมที ่เชื ่อมต อผ านพอร ต USB ของบอร ด 
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#include <POP32.h>

void setup()

{

  oled.text(0,0,”Hello POP-32");

  oled.show();

}

void loop()

{}

โปรแกรมที ่ 2-1 โค ดภาษา C/C++ ส ําหร ับทดสอบการแสดงข อความที ่จอแสดงผลของบอร ด 

(12) กล ับมาย ังหน าต างหล ักของโปรแกรม Arduino IDE พ ิมพ โค ดตามโปรแกรมที ่ 2-1 ส ําหร ับ
ทดสอบการทํ างาน จากนั้ นคลิ กปุ ม Upload

(13) เมื่ อการอั ปโหลดโปรแกรมสิ้ นสุ ดลง บอร ด  จะทํ างานทั นที 

บอร ด  แสดงข อความ Hello POP-32 ที่ จอแสดงผล OLED
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2.2 การติ ดตั้ งซอฟต แวร  Arduino IDE บนระบบปฏิ บั ติ การ MAC OS X

2.2.1 การติ ดตั้ ง Arduino IDE
มี ขั้ นตอนดั งนี้ 

(1) เชื่ อมต อคอมพิ วเตอร  MAC เข ากั บเครื อข ายอิ นเทอร เน็ ต จากนั้ นเป ดเว็ บบราวเซอร ไปยั ง
เว็ บไซต  Arduino ที่  https://www.arduino.cc จากนั้ นคลิ กที่ หั วข อ SOFTWARE ตามรู ปที่  2-16

ร ูปที ่ 2-16 หน าเว ็บของ Arduino ผ านเว ็บบราวเซอร บนคอมพิ วเตอร  MAC

ร ูปที ่ 2-17 แสดงล ิงก ดาวน โหลดไฟล ต ิดตั ้งซอฟต แวร  Arduino IDE ส ําหร ับระบบ ปฏิ บ ัต ิการ MAC OS X
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(2) เลื่ อนแถบลงมาด านล าง ค นหาหั วข อ Legacy  IDE จะพบลิ งก สํ าหรั บดาวน โหลดไฟล 
ติ ดตั้ งซอฟต แวร  Arduino IDE เวอร ชั่ น1.8.X สํ าหรั บ MAC OS X 10.10 ตามรู ปที่  2-17

(3) จากนั้ นจะปรากฏหน าต างตามรู ปที่  2-18 คลิ กที ่ปุ ม JUST DOWNLOAD เพื ่อดาวน โหลด
ไฟล ติ ดตั้ ง จะได ไฟล  arduino-1.8.19-macosx.zip

(4) ดั บเบ ิลคลิ กที ่ไฟล  .zip เพื่ อแตกไฟล  จากนั ้นแอปพลิ เคชั ่น Arduino จะถู กสร างขึ ้นมาตาม
รู ปที่  2-19

ร ูปที ่ 2-18 แสดงปุ ม JUST DOWNLOAD ส ําหร ับดาวน โหลดซอฟต แวร  Arduino IDE

ร ูปที ่ 2-19 แสดงแอปพล ิเคชั ่น Arduino
ส ําหร ับใช งาน
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(5) เพื ่อความเป นระเบ ียบหมวดหมู ของแอปพล ิเคชั ่น แนะน ําให ย ายแอปพล ิเคช่ั น Arduino ไป
ไว ในส วนของ Applications ของคอมพ ิวเตอร  MAC ตามร ูปที ่ 2-20 จากนั ้นเร ียกใช งาน Arduino IDE

2.2.2 การต ิดตั ้งฮาร ดแวร และไลบรารี สํ าหรั บใช งานบอร ด POP-32
เมื ่อติ ดตั้ งโปรแกรม Arduino IDE เรี ยบร อยแล ว ลํ าดั บถั ดไปคื อ การทํ าให โปรแกรม Arduino

IDE ทํ างานก ับบอร ด POP-32 ได ด วยการเพิ ่มข อมู ลทางฮาร ดแวร และต ิดตั ้งไลบราร ีสํ าหร ับการพั ฒนา
โปรแกรมด วยภาษา C/C++ ให ก ับ Arduino IDE รวมถ ึงท ําให เครื ่องมื อในการอ ัปโหลดโปรแกรมของ
Arduino IDE สามารถทํ าการอั ปโหลดโค ดมายั งบอร ด   ได 

มี ขั้ นตอนดั งนี้ 

(1) เป ดโปรแกรม Arduino IDE ขึ้ นมา โดยในครั้ งแรกสุ ดหลั งจากการติ ดตั้ งโปรแกรม ใน
กรณี ที่ ปรากฏหน าต างยื นยั นการเป ดใช งานตามรู ปที่  2-21 ให คลิ กปุ ม Open

ร ูปที ่ 2-20 แสดงแอปพล ิเคชั ่น Arduino ที ่ถ ูกย ายไปจ ัดเก ็บในส วนของ Applications

รู ปที่  2-21 แสดงหน าต างยื นยั นการเป ดใช งาน
โปรแกรม  Arduino ในครั ้งแรกหล ังการต ิดตั ้งใช งาน
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(2) หน าต างหลั กของโปรแกรม Arduino IDE จะปรากฏขึ้ นมาพร อมใช งานตามรู ปที่  2-22

(3) ในขณะที่ โปรแกรม Arduino IDE แอกตี ฟที่ แถบเมนู ด านบนให คลิ กเลื อกเมนู  Arduino
> Preferences…ตามรู ปที่  2-23

ร ูปที ่ 2-22 แสดงหน าต างหล ักของโปรแกรม Arduino IDE

ร ูปที ่ 2-23 แสดงการเล ือกเมน ู Preferences ของโปรแกรม ARduino IDE บนระบบปฏ ิบ ัต ิการ MAC OS X



POP-32 17

(4) หน าต าง Preferences จะปรากฏขึ้ นมาตามรู ปที่  2-24 ให ทํ าการตั้ งค าดั งนี้ 

๐ คลิ กที่ รายการ Verify code after upload เพื่ อนํ าเครื่ องหมายถู กออก

๐ คลิ กที่ รายการ Check for updates on startup เพื่ อนํ าเครื่ องหมายถู กออก

๐ ที่ รายการ Additional Boards Manager URLs: กํ าหนดค าเป น
https://github.com/INEXdev/ArduinoSTM32/raw/main/package_inex_

stm32_index.json

จากนั้ นคลิ กปุ ม OK เพื่ อยื นยั นการตั้ งค า

(5) เลื อกเมน ู Tools > Board:xxx > Boards Manager… ตามรู ปที่  2-25

(6) หน าต าง Boards Manager ปรากฏขึ้ นตามรู ปที ่ 2-26 ให พิ มพ ค นหาด วยคํ าว า INEX จะพบ
รายการตั วติ ดตั้ งข อมู ลทางฮาร ดแวร ชื่ อ INEX_STM32 ซึ่ งมี ข อมู ลของบอร ด  รวมอยู ด วย
จากนั้ นคลิ กปุ ม Install เพื่ อทํ าการติ ดตั้ ง

ร ูปที ่ 2-24 แสดงการตั ้งค าหน าต าง Preferences เพ่ื อเตร ียมการต ิดตั ้งข อม ูลของบอร ด 
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ร ูปที ่ 2-25 แสดงการเล ือกเป ด Boards Manager…

ร ูปที ่ 2-26 แสดงหน าต าง Boards Manager ส ําหร ับต ิดตั ้งไลบราร ีและข อม ูลทางฮาร ดแวร ของ INEX_STM32
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(7) จากนั ้นเข าสู กระบวนการต ิดตั ้งไลบราร ีตามร ูปที ่  2-27 รอจนกระทั ่งการติ ดตั ้งเสร ็จสมบ ูรณ 

ขั ้นตอนถ ัดไปเป นทดสอบอ ัปโหลดโปรแกรมไปย ังบอร ด   เพื ่อย ืนย ันว า การต ิดตั ้งข อม ูล
ฮาร ดแวร และไลบราร ีของบอร ด  ให ก ับโปรแกรม Arduino IDE ถ ูกต องและพร อมใช งาน

(8) ต อสาย USB เพื่ อเชื่ อมต อบอร ด  กั บคอมพิ วเตอร 

(9) จ ายไฟเลี้ ยงให บอร ด  เป ดสวิ ตช  POWER

(10) ในขณะที่ โปรแกรม Arduino IDE แอกตี ฟ ที่ แถบเมนู ด านบนให คลิ กเลื อกเมนู  Tools >
Board:xxx > INEX   STEM32 > POP-32 ตามรู ปที่  2-28

(11) เลื อกวิ ธี การอั ปโหลดโค ด โดยเลื อกเมนู  Tools > Upload method: “HID Bootloader
2.2”>HID Bootloader 2.2 ตามรู ปที่  2-29

ร ูปที ่ 2-27 แสดงกระบวนการต ิดตั ้งไลบราร ีในกลุ ม INEX_STM32

ร ูปที ่ 2-28  แสดงการเล ือกบอร ด POP-32
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(12) เลื อกพอร ตอนุ กรมสํ าหรั บติ ดต อกั บโปรแกรม Arduino IDE โดยเลื อกเมนู  Tools >
Port:xxx > /dev/cu.usbmodemXXXXX ตามรู ปที่  2-30 โดยในส วนนี้ หมายเลขพอร ตเชื่ อมต อ USB
ระบบปฏิ บั ติ การจะเป นตั วกํ าหนดขึ้ นมาอี กทอดหนึ่ ง

(13)  ที ่หน าต างหล ักของโปรแกรม Arduino IDE พ ิมพ โค ดตามโปรแกรมที ่ 2-1 สํ าหร ับทดสอบ
การแสดงข อความที่ หน าจอแสดงผล OLED จากนั้ นคลิ กปุ ม Upload

(14) เมื่ อการอั ปโหลดโปรแกรมสิ้ นสุ ดลง บอร ด  จะทํ างานทั นที 

ที ่จอแสดงผล OLED ของบอร ด   แสดงข อความ Hello POP-32

ร ูปที ่ 2-29 แสดงการเล ือกว ิธ ีการอ ัปโหลดสํ าหร ับบอร ด POP-32 ของ Arduino IDE

ร ูปที ่ 2-30 การเล ือกหมายเลขพอร ตส ําหร ับการสื ่อสารข อม ูลอน ุกรมก ับบอร ด POP-32




